I’m frustrated

MN Wild Boom

I downloaded the Minnesota Wild boom theme, but its saying that its not compatible with the version of firefox im using. Problem with that is that i have the most current version of firefox there is - 3.5.2. help anyone???
1 person has
this problem
+1
Reply